Avatar editing currently malfunctioning?


manXcat
Full Access
Joined: 02/17/18
Posts: 1,425

The end user Avatar editing function is not working as it should per its instructions and as previously experienced. I am full access sub. Could you investigate please?

I tried to edit (change) my current custom avatar yesterday, several times as it failed to action the change on the initial or subsequent attempts. Pretty sure I adhered to the required protocols.

i.e. Selected edit avatar, selected custom avatar upload, and uploaded a 200 × 200px 20kb avatar image from my PC conforming to all the outlined format requirements.

Tried all three .jpg, .gif and .png formats. Same result each time. The image change wasn't applied. The image is a guitar, nothing controversial or obscene a filter might have prohibited unless there's an unstated manual review and approval process prior to it appearing?

My upload indicated as a successful upload on each occasion. I selected save change as my final step on each attempt.

When I closed and relaunched the GT page, selected and entered my account, no avatar was selected by auto-default and yet my previous unupdated custom avatar was displaying although instructions state selecting no avatar active will delete any previous custom avatar. What the!???

I tried editing on both PC and Android tablet. I manually refreshed the browser page to ensure I wasn't reloading from cache.

Can you look into this please and advise? If it's 'finger trouble' my end I'd like to know, but prima facie It appears the custom avatar editing function is not working as it should at the server end.

Thank you.


# 1
Guitar Tricks Admin
Full Access
Joined: 09/28/05
Posts: 3,257

Hi manXcat,

Thanks for bringing this to our attention. You might have found a bug in our system! We're going to look into this and hopefully get the problem fixed soon.

Thanks.


If you have any questions, comments, or concerns, please contact us.
# 2
manXcat
Full Access
Joined: 02/17/18
Posts: 1,425

Update

I can confirm a server end software malfunction.

I've reverted to no avatar because of it.

I suspect that contrary to the advisory that paraphrased, the formerly uploaded and/or deployed custom avatar will be deleted upon selecting any option of either, 1. no avatar or, 2. upload (new) custom avatar or, 3. a GT selectable avatar, the preceding avatar isn't actually being deleted.

Subsequently, upon selecting load custom avatar and proceeding through the upload and save sequence, the application loads all prior uploaded avatars overlayed in an image which appears as a confused multi-image and partially corrupted palette.

I've tried uploading all the acceptable formats (.png, .gif, .jpg) sized per provided guidelines max spec and lower multiple times, refreshing cache, logging out and logging back in, closing and restarting the app (Android) and browser window Win 10x64 (desktop PC), all without success. Different images as well, so I can confirm it's not caused by an actual corrupted original image palette pe se.


# 3
Guitar Tricks Admin
Full Access
Joined: 09/28/05
Posts: 3,257

Hi there,

This is something we're still working on! We'll let you know as soon as possible when it's fixed. Apologies for the inconvenience and thank you for your patience.


If you have any questions, comments, or concerns, please contact us.
# 4
Sasha-B
Registered User
Joined: 08/10/18
Posts: 114

same issue as already noted.


2021 Iris CH

2021 G&L ASAT Classic Tribute

# 5
lindell.baker
Full Access
Joined: 08/16/22
Posts: 5

Im having the same issue. Will not save my changes to custom avatar. I see this issue goes back several years (at least 4 years) and it appears nothing has been done to address the bug. How bout we get this fixed! Do you always take so long to fix bugs? My file is less than 40 KB and 240x240 pixels. All seems good except then I click on save changes nothing happens. Log out and back in and no changes were saved.


# 6